今天在帮客户解决模板问题的时候,发现一个JQ多个引用一起出现报错问题

比如
头部文件有
<script src="https://libs.baidu.com/jquery/1.9.1/jquery.min.js";></script>

然后尾部文件有
<script src="https://libs.baidu.com/jquery/1.8.3/jquery.min.js";></script>

两个JQ的引用就出现了报错,然后网上找了一下,发现解决办法

<script src="jquery-1.5.js"></script>
<script src="jquery-1.11.js"></script>

<script>
// 现在window.$和window.jQuery是1.11版本:
console.log($().jquery); // => '1.11.0'

var $jq = jQuery.noConflict(true);
// 现在window.$和window.jQuery被恢复成1.5版本:

console.log($().jquery); // => '1.5.0'
// 可以通过$jq访问1.11版本的jQuery了

</script>

上面的那段代码是网上的,原处:https://blog.csdn.net/luxianping/article/details/48500397

然后我是这样写的

头部文件有
<script src="https://libs.baidu.com/jquery/1.9.1/jquery.min.js"></script>

然后尾部文件有
<script src="https://libs.baidu.com/jquery/1.8.3/jquery.min.js"></script>
<script>
    var $jq = $.noConflict(true);
</script>

然后就不报错了。有大佬可以一起探讨一下

最后修改:2020 年 05 月 14 日 06 : 07 PM
如果觉得我的文章对你有用,请随意赞赏